Known Issues & limits

Known Issues & limits

Here is where you can find a list of known issues either currently being worked on by the ADvendio team or known Salesforce issues. Where possible, we will also provide information on workarounds.

Version 2.180 and up: Issue with SalesForce Lookup Filter

  1. Issue: In Salesforce Classic, lookup filters could be configured as Required or Optional, and optional filters worked as intended. In Lightning Experience, however, all lookup filters are treated as required even if marked optional in Setup and users cannot see all records in the lookup field.This limits the customer’s ability to select the records they need.

    Screenshot 2025-08-19 at 11.05.22.png

Cause: As this is a known Salesforce issue (Salesforce IdeaExchange).

Solution: We cannot fix it globally for all fields in ADvendio. However, we deactivated the lookup filter specifically for the Account field on Media Campaigns to fulfill the customer’s requirement. If you want us to deactivate this lookup filter for any other fields please contact ADvendio support.

Version 2.180 and up: The Validation on From/Until Date in Campaign builder disappears once Tabs are changed

  1. Issue: Currently the from and until date validation works fine if the dates are not in the respective order or are in the past.However, we we switch tabs the error message disappears

Solution: We are working on a solution, which will be provided via patch as soon as possible.

Version 2.178 and up: Google DV360: Submit of Buying Items fails because of political ads setting

  1. Issue: It is currently not possible to submit new Buying Items to DV360, the following error message is shown:

Error: Line Item couldn't be saved. To save your line item, you'll need to confirm if your line item contains EU political ads.
Checkbox on False.png

Cause: A mandatory change on the DV360 Platform, now requires to explicitly set this flag, which previously was not yet added to our integration. Unfortunately there is currently no workaround, as out integration does not include this setting and DV360 strictly requires it to be set either positive or false.

Solution: We are working on a solution, which will be provided via patch as soon as possible.

  1. Issue :The "Buying Item Start Time and End Time" functionality is currently not supported for the following locales:

    • Arabic (Egypt)

    • Arabic (Saudi Arabia)

    • Arabic (United Arab Emirates)

    • English (Australia)

    • English (Canada)

    • English (India)

    • English (New Zealand)

    • English (Pakistan)

    • French (Canada)

Solution: If you are operating in one of the locales listed above, or any other locale where this functionality is not performing as expected, please report the issue to Advendio Support. Our team will investigate and work to provide a resolution in a timely manner.

Version 2.178.4 and up: Scheduled Delivery Reports from Connections are failing

Issue: After installing the new ADvendio version, scheduled delivery reports for your connections are not importing data anymore into Salesforce. You might receive a failure email stating the following message:

Scheduler: failed to execute scheduled job: jobId: 707J800001zPWyP, class: common.apex.async.AsyncApexJobObject, reason: Attempt to de-reference a null object

Cause: Due to technical enhancements in our reporting framework, all clients updating to ADvendio version 2.178.4 (or higher) from an older version must re-initialize their scheduled delivery reports. This is a mandatory step to prevent interruptions in data delivery, which can affect automated invoicing and reporting.

Solution: For each of your previously scheduled delivery reports, please follow these simple steps:

  1. Navigate to the Connection Import Center.

  2. For each of the scheduled delivery reports in the list, click the Edit icon.

  3. You do not need to make any changes. Simply click Save immediately.

This simple action will re-initialize the schedule and ensure your delivery data continues to sync seamlessly. Please also take these steps

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Version 2.178 and up: Xandr: Invalid end date error on Fixed Price bookings

Issue:

Bookings of Campaign Items that result in ‘flat fee’ for Xandr are resulting in an API error. This affects Campaign Items with the billing category ‘Fixed Price’ or 'CPD'

Warning : Error while running Xandr booking job: Id: SYNTAX, Message: Invalid end_date. Must have the following format: Y-m-d 23:59:59

Cause

We are still investigating root cause of this issue.

Solution

We have fixed the issue, and the following versions have been patched: 2.177.15 & 2.178.6.

Version 2.175 and up: ‘Import only Active IDs’ option not working in Transfer to ADvendio

Issue:
The Option ‘Import only Active IDs’ in Transfer to ADvendio is currently not working as expected, resulting that for certain integrations and types, inactive connection IDs are imported regardless.

Cause:
For Google AdManager a bug in our logic causes problems. For platforms like Equative and Adswizz we need to reconfirm for which imports a status is even tracked in the platform.

Solution:
We are currently investigating a fix and will update as soon as a ETA for the fix is confirmed.

Version 2.176: Dashboard Limit Error During Installation (resolved in 2.176.1)

Issue:
When installing version 2.176 into a Salesforce organization, an error may occur:
Error Message:
"You have reached the limit for dashboards run as the logged-in user."

Cause:
Salesforce Enterprise Edition has a limit of 5 dynamic dashboards. Version 2.176 introduces an additional dynamic dashboard in the package, which may cause organizations that are already at their limit to encounter this error during installation.

Solution:
We updated the dashboard settings to use a fixed running user instead of a dynamic view in patch 2.176.1, preventing it from counting toward the dynamic dashboard limit in future versions.

Version 2.175: Notice for Clients Upgrading to Version 2.175 or Higher

Clients upgrading from versions below 2.175 to version 2.175 or higher may encounter the following error during installation:

Error Message: "The post install script failed."

To prevent this issue, we recommend the following workaround:

  • Deactivate the currently active quote preference before installation.

  • Reactivate it after the installation is complete.

Should you require assistance or if the issue persists, please do not hesitate to contact our support team. We are happy to help you analyze the root cause and ensure a proper resolution.

Version 2.173 or Version 2.175: Media Search Lookup Filter Issue

We would like to inform you that clients using major (or patch) versions 2.173 or 2.175 may experience issues within the Media Search. Specifically, when a rate card is selected, lookup filters for sites or other related objects may not display all available values.

This issue has been resolved in the following patch versions:

  • 2.173.16

  • 2.175.4

We recommend installing the respective patch version to resolve the issue. If the problem persists after the update, please do not hesitate to contact our support team for further assistance.

Thank you for your understanding and continued support.

Version 2.173: Misleading error message “This feature is not part of your current ADvendio license.”

As part of our change in version 2.173 requiring the action “Schedule a weekly Apex job and run it.“ we added an error message to features that don’t have this job scheduled: Breaking Change: Version 2.173 and above: Update of License Information for every ADvendio org

Unfortunately it was found that if something goes wrong with the schedule you might see the error “This feature is not part of your current ADvendio license.” although you possibly have all required features activated.

Steps to take:

  1. If you think you should be able to see the component follow the steps described here and just click the button to schedule again. If you then refresh the feature you were not allowed to see before, the error message should be gone. If not, continue with step 2. If you repeatedly need to click the button after a few days please reach out to our support team as well as something might be wrong.

  2. Make sure your licenses are activated for the feature you’d like to use. For this you can contact our Support team.

We are planning to fix this soon and will update here once the solution is delivered. Until then please use the workaround described in step 1.

Installation Errors in 2.173 due to deprecated components

The installation of 2.173 fails in your environment and produces an error message “ApexPage You can't change the standard controller object MediaCampaign__c because this page is referenced in the page layout Media Campaign Layout. CampaignItemRelatedList: You can't change the standard controller object MediaCampaign__c because this page is referenced in the page layout Media Campaign Layout.“.

To solve this issue please manually remove the deprecated visualforce page CampaignItemRelatedList from your Media Campaign Layout and retry the installation afterwards.

Below you see two screenshots of an example page layout with the deprecated list that needs to be removed.

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Installation Errors in 2.173 due to Connections Lightning Page

Summary:

This Issue should not appear anymore for most customers, starting patch 2.173.1; In case you should still see similar error message, please confirm if all steps in the solution section are done.

The installation of 2.173 failed in your environment and produces an error message regarding the FlexiPage (ConnectionRecordPage), that states certain picklist values are not existing:

 

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Problem: 1. FlexiPage(ConnectionRecordPage) Component [lst:dynamicRelatedList] attribute [adminFilters]: CMS-Key-values isn't a valid picklist value.

Solution:

In order to solve this problem, you need to make sure, all picklist values which are required for ADvendio features and are used in the Lightning Page, are existing and active in your Salesforce Org. This might require to manually create new picklist values, since Salesforce does not automatically update new picklist values in existing managed package fields.

Please make sure to use the exact spelling listed here and turn the values to active. They do not need to be assigned to record types or page layouts.

 

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Here is a list of all required fields and picklist values:

Object: Connection ID

Field: Category

Values:

  • CMS-Key-values

  • Key-values

  • Inventory

  • Geo

  • Audience Segments

  • Accounts

Could not remove Contents in version 2.173

This Issue was fixed in patch 2.173.2. 13. Release Notes

There was a Known Issue in versions 2.173 and 2.173.1 where unselecting single Contents via the targeting component of the Campaign Builder appeared not to remove them as expected. You noticed when going back into the component and in the summary that the content was not really removed.

 

Error when saving Campaign Items with Publication Dates in version 2.173

This Issue was fixed in patch 2.173.2. 13. Release Notes

There was a Known Issue in versions 2.173 and 2.173.1 where saving a Campaign Item with Publication Dates from the Campaign Builder resulted in an error message and not saving the Publication Dates. An error during the saving process was shown then saying “Insert failed. First exception on row 0; first error: INVALID_FIELD, Cannot specify both an external ID reference ADvendio__PublicationDate__r and a salesforce id, ADvendio__PublicationDate__c: [].“.

Error when using certain features: 0: [ADvendio__FromHour__c]

Summary:

Some customers are reporting an error when they use certain features such as the optimizer, clone and submit to adserver:

"Cloning ADvendio__Campaign_Item__c records: - Insert failed. First exception on row 3; first error: INVALID_OR_NULL_FOR_RESTRICTED_PICKLIST, bad value for restricted picklist field: 0: [ADvendio__FromHour__c]"

Solution:

In setup navigate to the “from (hour)” & “minute (hour)” fields, manually add a 0 picklist value, and also add it to the Record Type Picklist value assignment - selected values column (see below).

Screenshot 2024-07-22 at 10.44.57.png

We provided solutions for the issue in version 2.171.21, 2.173 and up.

Essential org information or user based information requires a Campaign Builder settings update

Features Impacted: Campaign Builder
Version: 2.169 and above

When essential information is changed in the setup of an org like:

  • administration decimal values

  • picklist values inactive / picklist value record type assignment

  • certain feature settings that impact the campaign builder

  • locales

  • languages

  • currencies

Then you might have to resave the item configuration settings.

We are still in discussions how we could solve this in a better way.

Submitting an Equativ(SMART) item gives an 'External Account ID record is a duplicate of one of existing records' error

Features Impacted: Submit to Ad Server/ Equativ integration
Version: 1.257
Reference ticket: AD-7963

We experienced a wrong warning error message coming from Salesforce when submitting an Equativ item to the AdServer.
This error doesn’t impact the submission process (the user is not affected in a negative way), but we worked on a fix that will be implemented in patch 2.157.1.

The “Roadblocking” feature in Xandr is enabled by default

Features impacted: Submit to Ad Server/ Xandr integration
Version: All versions
Workarounds: Manually disable the feature “Roadblocking” in your settings.

A new issue is in the process of being fixed. Due to a recent change within Xandr, All new Media Campaign items with the “Augmented” AD type are pushed with the “Roadblocking” feature automatically enabled. This easily could be changed in the “Roadblocking” settings. Currently, there is no way to change this setting from within ADvendio.

Select “Disable Roadblocking”.

Users need to confirm a license check before using certain features

Features impacted: Features of the ADvendio Connect & Finance module
Version: 2.131 and up
Workarounds: Your administrator can schedule the license check to run automatically in the background as mentioned in section 2.3 here: 7.1.3 Manage Users and Licenses. Our recommendation is to schedule the job to run once a day, then your users should not see the confirmation window anymore.

Sometimes your users will see a window asking them to confirm the feature activation and license check. Then the user needs to click yes in order to start a license synch and continue using ADvendio. In the wake of our improvements to meet the security guidelines of Salesforce we needed to add the confirmation dialog instead of handling this check in the background without being visible to the user. As Salesforce requires, processes which change the user's data, in this case, the saved license information, need to be actively confirmed by the user, so that he is aware of what is happening. Once the license check is done the feature will work as expected and the user should not see the confirmation anymore. From time to time it might appear again and needs to be confirmed again.

Sometime a user needs to go back and start the current feature again after the confirmation, in order to get it to work. If at a second try you still see the confirmation window and nothing seems to change, please contact support@advendio.com

End Campaign Item

Features impacted: End Campaign Item Function
Version: 2.128
Workarounds: see below for more details

Our newly implemented End Campaign Item Function is currently experiencing issues when ending items with an AdServer Login. Due to Salesforce limitations in patching new versions of a flow, the End Campaign Item component in version 2.128 can only be used to end non-delivery data relevant, i.e. no AdServer Login in the AdType for CPM, CPC, cCPM and CPCV. A new version of the flow will be provided in version 2.129.

CPU Limits

Features impacted: Preinvoice Creation, Optimizer and Cancellation Wizard
Version: miscellaneous < 2.126
Workarounds: see below for more details

Users who are creating Preinvoices for many Campaign Items or cancelling many Invoices or Campaign Items which would result in many cancellations have been experiencing CPU limits. This is a known issue due to the number of changes which are triggered and can result in hitting the CPU limit set by Salesforce.

In order to improve the performance, the 7.6.1 Configure Mapping BA has been hardcoded for all new customers. Existing customers or customers who are experiencing CPU limits should take the following steps:

  • Clear the old mapping BA by deleting the Source and Target sets of data

  • Only use the Mapping BA was necessary to overwrite default Mapping BA values

Users can also try

  • Break larger Media Campaigns (>100 items) into smaller optimizing versions and/or

  • cancel invoiced invoices individually

If the issue persists, or the option to break down items into smaller versions/cancel invoices individually is not possible in your given case, please feel free to contact us at support@advendio.com.

Email notifications not sent

Features impacted: all features where processes initiate an email notification
Version: 2.125
Workarounds: none

With ADvendio Version 2.125 - Spring 2020 major release, there is an issue with the email notifications for processes with user interaction/where results emails are generated. This results in emails not being sent to users notifying them, for example, of batch results, availability checks, accounting records results, etc. All customers are recommended to update to at least Version 2.125.1 as soon as possible to ensure users receive all email notifications/communications as expected. The installation link and release notes can be found here.

Invoices only for Package Header

Features impacted: preinvoice creation
Version: >2.125.1
Workarounds: delete preinvoices

Prior to ADvendio version 2.125.1, where there was a gap in the runtime of a Package (i.e it ran from January to June but had no items in April), there would be a zero invoice created for just the Package Header. The amount of all fields are zero and these preinvoices could simply be deleted without invoicing.

Users require permission to view the Org Setup in order to perform actions with external Systems (AdServers, SSPs, DSPs etc.) → Fixed with version 2.131

Features impacted: Check Availability, Submit to AdServer, Delivery Data Reports
Version: miscellaneous < 2.127
Workarounds: This has been fixed with version 2.131, find more information on the permission settings needed for ADvendio Connect here: 7.3.8 Which permissions and rights are needed for a user to access ADvendio Connect and the integration of third party systems?

At the moment it is not possible for users to access any actions related to external systems (e.g. checking of availabilities, submit, update of status) without them having permission to also access the org setup. If this permission is not set in the user profile or assigned permission sets, they will always see the following error message:

“No Salesforce Connection specified”

Please make sure the permission “View Setup” in the system permissions is activated for the relevant users.

Deleting a Media Campaign will call the previous action taken after deletion

Due to a Salesforce behaviour to navigate to the last page opened when a record is getting deleted it might be that certain actions will be called again with a deleted Media Campaign.

Please note that if this happens with the Check Availability or Submit to AdServer processes then no real action will be taken due to the deleted campaign.

Issue with Pre-Invoice Generation for Customers Using Total Payment Interval & Merge All Cancellation

Features impacted: Total Payment Interval & Merge All Cancellation
Version: 2.173
Workarounds: If you have been using Total Payment Interval and Merge All Cancellation for an extended period, we do not recommend updating to version 2.173+ at this time to avoid potential inconsistencies in pre-invoice generation

We want to share an important update regarding pre-invoice generation behavior in version 2.173+ for customers who have been using Total Payment Interval and Merge All Cancellation for several years.

In earlier versions (up to 2.171), pre-invoice generation recognized Merge All invoice items and ensured that new invoice items were not created with different accounting dates. This was achieved by aligning the accounting date based on the Media Campaign Start Date rather than the Invoice Item Start Date.

However, in version 2.173+, the pre-invoice generation logic has been changed, and it now creates new invoice items with different accounting dates (based on the Media Campaign Start Date instead of the Invoice Item Start Date). This could lead to discrepancies in invoicing for long-standing users of the Merge All Cancellation feature.

We are currently reviewing this and will inform about the fixes.